Dubbele waarden zoeken met AANTAL.ALS() en ALS()

Geplaatst in Functies door Exhelp | Tags: , , , , ,
Van toepassing op: Excel 2003, Excel 2007, Excel 2010, Excel 2013

Ik heb het eerder al gehad over het traceren van dubbele waarden in een lijst. Hier maakte ik gebruik van Excel’s ‘voorwaardelijke opmaak’. Hier bespreken we een andere manier om het op te lossen; met functies.

Als voorbeeld nemen we opnieuw een boekenlijst…

We gebruiken hiervoor de AANTAL.ALS() functie in combinatie met ALS(). We kijken hoe vaak een waarde voor komt in de lijst en zullen op basis daarvan het volgende uitvoeren:

  • Eén keer = unieke waarde = bijhouden
  • Meer dan één keer = dubbele waarde = verwijderen

In cel ‘C2’ plaatsen we volgende formule:

=ALS(AANTAL.ALS(A2:A30;A2)>1;"Schrappen";"")

We voeren deze formule door naar beneden waardoor de dubbele waarden in kolom ‘C’ worden aangeduid met “Schrappen”.

Het enige dat we nu nog moeten doen is een filter opzetten, om de overbodige lijnen in één keer te verwijderen uit het blad.

Verwijder de gefilterde rijen, zet je filter terug uit, en je zal zien dat je lijst enkel nog unieke waarden bevat.

Bijlagen

dubbelewaarden
dubbelewaarden.xlsx (20 KB)

 

2 reacties op “Dubbele waarden zoeken met AANTAL.ALS() en ALS()”

  • kunt u nog even verduidelijken hoe dat filter werkt, en hoe dat in te stellen??

    B.v.d. Louis

  • Hallo Louis,

    Selecteer je lijst en kies dan in het lint voor GEGEVENS en vervolgens FILTER.

Plaats een reactie

U moet ingelogd zijn om te reageren.

Login

Forums

Exhelp

Meest recente berichten

TAGS



Creative Commons Licentie
Op dit werk is een Creative
Commons Licentie
van toepassing.